Ahsay Known Issue:
Backup job is started multiple times (causing subsequent backup error for all backup types)
Product Version:
AhsayOBM / AhsayACB: Pre-7.3.2.0
OS: Windows
Problem Description:
When performing a backup of any type, the backup start message is received multiple times in the backup report:
Start [ All platforms (AhsaySupport), AhsayOBM x.x.x.x ]
Start running pre-commands
Start [ All platforms (AhsaySupport), AhsayOBM x.x.x.x ]
Start running pre-commands
Note:
In some cases, there may not be multiple start entries.
With the backup job starting multiple times, the following error messages maybe displayed for different backup set type:
File backup:
Backup skipped.
Or
Unable to do Offsite backup, Error= [BlockDB.init] Error initializing bptree
Exchange Server backup:
CExBackup::backupService:HrESEBackupSetup: Error Number 0x50d: Either the target process, or the target thread's containing process, is a protected process.
Lotus Domino backup:
[Error] Log backup completed with error="Archiving of transaction logs already in progress."
Cause:
The messages suggest that the backup job had been started multiple times. This issue can occurs if:
- There are multiple scheduler processes running on the client computer.
- There are multiple computer within the same domain with the same computer name.
- There are multiple entries listed in the home.txt file.
Resolution:
To resolve the issue, perform the following steps:
1. Ensure that there is only one single scheduler process running:
Shutdown the backup scheduler by:
[ Control Panel ] > [ Administrative Tools ] > [ Services ] > [ Online Backup Scheduler (AhsayACB / OBM) ]
Open Task Manager, ensure that there is no 'bschJW.exe' process that is still running. Kill the process if there is:
2. Re-start the backup scheduler afterward.
- Check if there maybe multiple computers with the same computer name:
- Check if there are multiple computers within the same domain with AhsayOBM / ACB installed.
For example, if there are 2 computers on the network with computer name 'file_server'. If a user had installed, and logged onto AhsayOBM on both computers, backup set(s) that is configured to be run on 'file_server' (e.g. Run scheduled backup on this computer enabled) will be started on both computer at the scheduled time:
To resolve the issue, re-name the computer to a different computer name. Ensure that the 'Run scheduled backup on this computer' setting is enabled for the intended computer only.
Ensure that there is only one entry within the home.txt file:
1. Open the home.txt file found within the AhsayOBM / ACB installation directory with a text editor.
2. Check if there are multiple entries written within the home.txt file:
home.txt
C:\Users\username1\.obm
C:\Users\username2\.obm
C:\Users\username3\.obm
C:\Users\backup_account\.obm
3. Remove all entries except the one with the operating system account profile, that the backup job should be performed with:
home.txt (Updated)
C:\Users\backup_account\.obm
4. Save and exit.
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