Ahsay Known Issue:
The file or directory is corrupted and unreadable (3158)
Product Version:
AhsayOBS: Pre-7.3.2.0
OS: All platforms
Problem Description:
When performing a backup of any type, the following error message is received in the backup report:
The file or directory is corrupted and unreadable
[Error][Updated File] File="directory\file" Error="[com.ahsay.obc.core.bset.file.H] <Reply><Err>The file or directory is corrupted and unreadable</Err></Reply>"
Cause:
The message suggests that the corresponding data file on AhsayOBS is corrupted.
Resolution:
To resolve the issue, check if there is hardware or I/O issue with the corresponding User Home volume.
Windows:
For AhsayOBS running on Windows, check under [Control Panel] > [Administrative Tools] > [Event Viewer] if an error could be found. If a disk error is found, perform a check disk on the corresponding partition by entering the command "chkdsk /f" in command prompt.
Linux / Unix:
For AhsayOBS running on Linux / Unix, depending on the distribution, you could try entering the command "cat /var/log/messages" and verify if an error could be found. If a disk error is found, please perform a checkdisk on the corresponding partition by enter the command "/sbin/fsck" and "/sbin/e2fsck" (with the partition un-mount).
Network volume:
If the User Home in concern is a network drive, check on the network setting of the corresponding drive, verify if the "Log on" account of the AhsayOBS service has sufficient permission right(s) to access the designated User Home directory.
1. Open [Control Panel] > [Administrative Tools] > [Services] > [Ahsay Offsite Backup Server and Replication Server] > [Log on].
2. Select the [This Account] option.
3. Enter the Login Credentials.
4. Restart the [Ahsay Offsite Backup Server and Replication Server] service.
Perform a User Storage rebuild for the corresponding user, and then perform another backup job afterward.
Comments
0 comments
Article is closed for comments.