Ahsay Known Issue:
Unable to do Offsite backup (Error initializing bptree) (3149)
Product Version:
AhsayACB / AhsayOBM: All
OS: All platforms
Problem Description:
When performing a backup of any type, the following error message is received in the backup report:
Unable to do Offsite backup, Error= [BlockDB.init] Error initializing bptree
Cause:
The message suggests that the remote file list cannot be retrieved.
There may be an issue with the backup file index located on AhsayOBS, or there may be an issue with the temporary directory configured for the backup set on the client computer.
Resolution:
To resolve the issue, please refer to the following steps:
Known issue with older versions of AhsayOBS
Ensure that the backup server and client application are both on the latest and most stable version of the product.
To upgrade the backup server and client application to the latest release, refer to the Ahsay Software Upgrade Guide.
Possible disk issue on the User Home volumes
Check if there is hardware issue with the corresponding User Home volume.
For AhsayOBS installation on Windows:
Check under [Control Panel] > [Administrative Tools] > [Event Viewer] if an error could be found.
If a disk error is found, perform a check disk on the corresponding partition by entering the command "chkdsk /f" in command prompt.
For AhsayOBS installation on Linux / Unix:
Depending on the distribution, you could try entering the command "cat /var/log/messages" and verify if an error could be found.
If a disk error is found, please perform a checkdisk on the corresponding partition by enter the command "/sbin/fsck" and "/sbin/e2fsck" (with the partition un-mount).
For AhsayOBS with remote user home (e.g. network shared path):
If the User Home in concern is a network drive, check on the network setting of the corresponding drive, verify if the "Log on" account of the AhsayOBS service has sufficient permission right(s) to access the designated User Home directory.
Open [Control Panel] > [Administrative Tools] > [Services] > [Ahsay Offsite Backup Server and Replication Server] > [Log on]
Select the [This Account] option
Enter the Login Credentials
Restart the [Ahsay Offsite Backup Server and Replication Server] service
I/O utilization and location of the User Home volumes
For AhsayOBS with 'local' user home (e.g. locally attached disk):
Check on the I/O performance of the AhsayOBS server.
Check on the I/O utilization of the AhsayOBS server.
For computer running on Windows, you can view the I/O utilization with the Windows Performance Monitor.
For computer running on Linux / Mac OS X, you can view the I/O utilization with the command:
>iostat 1
or
>vmstat 1
If the I/O utilization of the disk in concern is constantly high, consider performing the backup job a an alternate time. Also, consider to add additional user home volumes, and then spreading the backup accounts onto the user home volumes evenly.
Note:
The commands above will only works for machine with local partition.
For AhsayOBS with remote user home (e.g. network shared path):
Check on the I/O performance of the Network Attached Storage (NAS) or Storage Area Network (SAN).
Check on the I/O utilization of the Network Attached Storage (NAS) or Storage Area Network (SAN).
Insufficient disk space available in the temporary directory
Check on the temporary directory specified for the backup set.
Ensure that there are sufficient disk space available in the temporary directory. If the temp directory is configured on a network drive, ensure that a stable connection can be established to the temporary directory.
Once the cause of the issue had been identified and resolved, perform a single backup set rebuild for the affected backup set:
Remove the backup file index for the affected backup set in the corresponding backup account's User Home:
${UserHome}\username\files\${backupset_id}\index.bdb
${UserHome}\username\files\${backupset_id}\r-index.bdb
Temporarily disable the backup schedule of the affected backup set.
Perform a single backup set rebuild for the corresponding backup set: FAQ: How do I run a single user rebuild? (3125)
Perform a backup job after the rebuild is complete to confirm if the problem has been resolved.
Re-enable the backup schedule for the backup set.
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